Discussion:
Installer does not work with keyboard?
(too old to reply)
Sean Reifschneider
2011-01-12 17:49:51 UTC
Permalink
I tried the PVE 1.7 installer today, but was having problems with the
mouse. This is via a "remote console" and there's apparently some sort of
issue where when I click the mouse button the mouse moves to the upper left
corner of the screen.

But I couldn't use the keyboard to do the install, it looks like a
problem with the installer holding the focus in the license text box.
<tab> doesn't take me to the different page elements, and while the "g"
in "I agree" has a line under it, I can't press Alt-g, ditto with Alt-A
for "Abort".

I can get feedback that the keyboard is working by getting some of the
license text highlighted (while I can't use the mouse to click the button,
it will often click in the text field as the cursor is racing up to the
left corner, which selects some text from the text box), and then I can use
the keyboard to scroll around in this license text box. But tab, alt-g and
alt-a continue to do nothing.

In fact, it looks like the "I agree" button is focused (there's the dashed
line around the inside of the button), but <space> doesn't select it.

Any thoughts?

Thanks,
Sean
--
"The phrase ``ship it!'' is one with long and deep resonances in my
benighted and antiquated big-software-dept career." -- John Shipman, 1998
Sean Reifschneider, Member of Technical Staff <***@tummy.com>
tummy.com, ltd. - Linux Consulting since 1995: Ask me about High Availability
Dietmar Maurer
2011-01-13 05:05:56 UTC
Permalink
I tried the PVE 1.7 installer today, but was having problems with the mouse. This
is via a "remote console" and there's apparently some sort of
What kind of remote console (exactly)?

- Dietmar
Sean Reifschneider
2011-01-14 07:42:49 UTC
Permalink
Post by Dietmar Maurer
What kind of remote console (exactly)?
I had replied to this earlier but don't see it on the list yet so maybe I
replied personally. I have more information on it though.

The KVM is the IPMI + KVM cards that are a part of the Supermicro
6026TT-BTF systems. It doesn't list a specific part number now that
they're integrated onto the motherboard, but it's very similar to the
AOC-SIMSO+ add-on boards that they used to have on the 5015B-MTB systems.
It's a board that supports IPMI plus a web server that allows you access to
system power and a Java applet that will connect you to the graphics/text
console and do remote media.

We did a firmware update on the IPMI board, and I also found a setting in
the main config menu (not in the remote console configuration) which
changes the mouse to "relative" positioning. Between the two of these I
was able to click buttons and complete the install.

During this, however, I made some more attempts at using the keyboard for
controlling the installer, with no luck. On none of the screens did the
indicated Alt+LETTER combinations work, and while TAB took the focus off
the "I agree" button, it didn't seem to put it anywhere useful, and
additional tabs didn't seem to bring it back. Additionaly, pressing space
when the "I agree" button was highlighted didn't seem to do anything.

So, there do definitely seem to be problems with driving the installer from
the keyboard.

Sean

Loading...